Having trouble with my IntelliPh- backflow into the tank and acid leaks
4 posts / 0 new
Last post
Posted

Hello-

I've had my IntelliPh for a little over a year, but recently I started to have some problems with it. First, I noticed that my Ph was drifting higher than it normally does. I double checked the history log and it still showed that acid was being dispensed, and I tried some manual acid doses and it appeared to work, so I just kept monitoring it. But after another few weeks, I noticed that the level in the acid tank was not going down at all. Again I checked the history, which showed that it was still dosing as programmed. Next I unhooked the feeder hose and did a manual dose (emptied back into a bottle of acid) to make sure that acid was actually flowing- it was. At this point I was a little stumped- I couldnt find anything wrong. I increased the dosage to 95%, and this has exposed what the real problem is. I went out today to check, and the level of the acid tank has gone up- it is now well over the 4 gallon max limit. Additionally, the concrete and equipment around the IntelliPh is now discolored, so it looks like acid leaked out somehow.

Everytime I do a manual dose, it looks fine (I have never seen any sort of leak). But somehow I am getting backflow into the tank, and apparently that eventually leads to some acid leaking from somewhere onto my equipment pad.

I have turned off the IntelliPh until I figure this out. Any ideas of what I can check?

Darren

Please Sign In to post comments
Darren,
Posted

Darren,
If you are getting water into your container, this is an indication that the check valve is not functioning and allowing this backflow of water. The first thing to do is replace this. The part number for the check valve is 521510.
Additionally, I recommend checking the pump head. If you are seeing any corrosion or rust forming, I recommend replacing this as well; part number 521514.

Please Sign In to post comments
I just realized my intelliph
Posted

I just realized my intelliph was not dispensing at all. Pentair is sending me a new pump head. Problem is that the same issue will reoccur. The "squeeze wheels" will rust out again as there is no weather tight seal at the view window. I've only had this installed about 7 months. That part should be weather sealed...bad design.

Please Sign In to post comments
This same thing happened to
Posted

This same thing happened to me and the pump was replaced by Pentair. It is a bad design and I foresee I will have the same problem within a year.

Please Sign In to post comments